What's with the Invalid_Response emails I'm getting?

We've had some questions recently about people getting Invalid_Response emails from xMatters. We know you get enough emails, and we want to help make sure you don't get any from us that you can't act on.

These Invalid_Response emails are sent when xMatters receives an email response to a notification that it already has a response for. There are a few scenarios that might cause this, each with its own unique solution.

Your security team is being (wisely) cautious

It's possible that your security team has put in place software to try to protect you from malicious links. This is good. But it can also muck up the URL response in the response email, adding entries to the URL which cause multiple responses to be sent back to xMatters. xMatters generally accepts the first response, but sends that Invalid_Response email for the additional responses.

Ask your security team to whitelist emails from xMatters so that these additions to the response URL are not added and xMatters just receives the one response.

You've already responded to the notification

We know you're keen to resolve any issues that cross your path, but you might be responding to the same event from different devices. If you don't have any delays set up between your devices in xMatters, they ALL receive the same notification at the same time. 

Keep being you, and keep responding to events. But only respond to the notification on one device. Better yet, set up delays between your devices in xMatters – that way we'll only notify you on more than one device if you don't respond on the first one. 

One of your teammates is already on it 

It could be that one of your teammates has already responded to the event in a way that ends the event escalation, meaning you don't need to respond. If you do, you get that Invalid_Response email.

There are a couple of things you can try to stop this. First, add delays between the people in your group. This gives the first person on the list a chance to respond before xMatters notifies you. If that doesn't work, check how the Response Options/Actions of a Communication Plan are set up – it might be that you need to tweak these to let your team respond in a way that does not cause others to get Invalid_Response emails.

Have more questions? Submit a request

1 Comments

  • 0
    Avatar
    Josh Means

    We ran into this issue with a recent implementation of Mimecast for front-end protection.  The URL masking messed with our xM links and confused the heck out of our users during our first quarterly test post implementation.  Easy fix, but something we completely overlooked.

Please sign in to leave a comment.
Powered by Zendesk