How to defend against the Sentinel Protection exploit

Background

The xMatters 5.1 installer initiates the CTADE 11 installer which in turn installs the Sentinel Protection drivers v7.3.2. These drivers have been found to be vulnerable to directory traversal attacks.

 

To protect against this security vulnerability, we suggest that you upgrade your Sentinel Protection drivers to v7.6.5 (attached to this article). Syntellect has verified the sentinel drivers as compatible with CTADE v11; xMatters has also validated this compatibility.

Note: This article applies to xMatters 5.1.

To upgrade your Sentinel Protection drivers to v7.6.5:

  1. Shut down the xMatters node.
  2. Stop the Dialogic service.
  3. Run the Sentinel Protection Installer v7.6.5 (attached).
    Note: There is no need to uninstall the previous version as the installer will upgrade the drivers.
  4. Perform a full installation with the default settings.
  5. Reboot the server.
  6. Once the server has started, navigate to the following location to confirm that the Sentinel Protection drivers have been upgraded:
    C:\Program Files (x86)\SafeNet Sentinel\Sentinel Protection Installer\7.6.5
    Note: You can also verify the version by locating the program via the Windows Control Panel (in Windows 7, you can find installed programs at Control Panel\Programs\Programs and Features).
  7. Restart the xMatters node and Dialogic service (if not automatically restarted).

xMatters Reference

DTN-3679

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk