End of Life notice for non-current versions of the Integration Agent

To continue delivering secure services to our customers, and in compliance with industry governance and standards, we are officially withdrawing all support for TLS version 1.0.

PLEASE NOTE: We originally planned to implement these changes on March 31, 2017. Based on feedback received from our customers, we decided to delay the end-of-life for TLS 1.0 until July 31, 2017. This article has been updated to reflect the new timeline.

When is this happening?

This change to our services includes the following end-of-life schedules:

  • Effective July 31, 2017, xMatters will no longer support versions of the Integration Agent prior to version 5.1.8.
  • After July 31, 2017, xMatters On-Demand will not accept connections from versions of the Integration Agent prior to version 5.1.8.

Due to security concerns with older versions of the product, we strongly recommend that all customers immediately update their installed Integration Agents to version 5.1.8. Customers using an integration agent to integrate with a hosted product or service are recommended to migrate their integrations to the Integration Builder.

What does this mean?

xMatters On-Demand will disable support for TLS 1.0 connections on July 31, 2017. Customers using the Integration Agent to communicate with xMatters On-Demand MUST update to the most recent version of the Integration Agent (minimum version 5.1.8), which supports the use of TLS 1.1 or greater. 

Furthermore, as of July 31, 2107, xMatters Client Assistance will no longer offer support for versions of the Integration Agent prior to version 5.1.8.

To help ensure secure connections for your data, we recommend that you upgrade to the latest version as soon as possible.

Why is this happening?

Due to recognized security issues with the TLS v1.0 protocol, industry and security professionals have recommended discontinuing the use of TLS v1.0, and upgrading all communications to a minimum of TLS v1.1. The latest version of the Integration Agent (5.1.8) and Java 1.8 support only TLS v1.2 or greater, and will be the minimum required versions after July 31, 2017.

What other products are affected?

HP/UX PA RISC Support Dropped

The HP/UX PA-RISC platform has also reached end of life, and we will no longer offer support for Integration Agents on this platform.

xMatters version 5.1 (all patch levels)

Premises customers using xMatters version 5.1 will not be required to update their Integration Agent version; however, older versions of the Integration Agent will no longer be supported by xMatters Client Assistance.

How do I upgrade?

The current version of the Integration Agent (5.1.8) is available for download on multiple platforms and provides backward compatibility with integrations created for previous versions of the agent. We recommend that you upgrade to this latest version as soon as possible.

How do I find more information?

For more information about why this change is required or the specific updates for your system, talk to your Client Success Manager. For technical assistance, or if you are having issues making any necessary upgrades, contact xMatters Client Assistance via the xMatters Support site.

 

 

Iain Rose

xMatters Product Management

Have more questions? Submit a request

1 Comments

  • 0
    Avatar
    Don Clark

    We originally planned to implement the end-of-life for TLS 1.0 on March 31, 2017. Based on feedback received from our customers, we decided to delay these changes until July 31, 2017. This article has been updated to reflect the new timeline.

Please sign in to leave a comment.
Powered by Zendesk