xMatters Agent won't start after installing - no service installed [Windows]

Problem

Running the following command to install xMatters Agent seems to complete but the agent will not start or show as a registered service:

msiexec /i xmattersagent-1.4.1-169.msi /l*v msilog.txt /qn HOST=company.xmatters.com PORT=443 XMATTERS_KEY=XyZaBc8s8meOJZ6qPRjbgWWLU4PfSyJaMojQ7emBmljz7890 API_KEY=1234583e-c1b8-45fa-b4c2-3444d4adwxyz

Environment

All xMatters Agent
Windows Server 2012

Resolution 

The issue may occur if the agent was not installed correctly. To resolve the issue:

  1. Uninstall the application using Control Panel -> Programs -> Uninstall Programs.
  2. Delete the following directory: C:\Program Files\xa
  3. As a Windows administrator, use the command prompt to run the installer without the /qn parameter.

This runs the installer in verbose mode and enables interactive prompting. This method may provide better indicators of potential issues.

For more information on installing an xMatters Agent, see the online help.

Cause

The initial installation may not have been run as Administrator or was otherwise blocked from completing.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk