0

Error 500 when using API to pull calendar for groups with slashes in the name

I'm trying to perform an API call to get the current on-call user for a particular group.

curl -u dschroeder:PASSWORD https://viasat.hosted.xmatters.com/api/xm/1/groups/GROUP-NAME/calendar

where GROUP-NAME is a urlencoded group name.  This works great, except when looking up a group that contains a slash in the name.  For example, "Infrastructure - Cloud - CNs/DNs/SANs" throws a 500 error:

$ curl -u dschroeder:PASSWORD https://viasat.hosted.xmatters.com/api/xm/1/groups/Infrastructure%20-%20Cloud%20-%20CNs%2FDNs%2FSANs/calendar

{"code":500,"reason":"Internal Server Error","message":"An unexpected error occurred. When communicating with support please provide this request identifier: 5aad722a-bac5-439a-bd80-da61aeb2409e"}

It's not just this one group, any group I've tried where the name contains a slash throws this 500 error, whereas group names containing spaces, hyphens, parentheses, etc. work just fine.  I tried searching through xMatters online documentation, but couldn't find anything on this, so that's why I'm contacting you.

Am I doing something blatantly wrong, or could this be a bug in the xMatters API?

6 comments

Please sign in to leave a comment.