403 error when trying to edit source code for a form message

Problem

When attempting to update a form message's source code, make changes in the editor view, send a message, or immediately after logging into xMatters, the browser Console may show a 403 error for a GET request and the user may be unable to complete the action.

Environment

  • All versions of xMatters

Resolution

This issue is typically related to customer-installed security or network controls (for example, firewall, proxy, or security software such as zScaler) that are blocking xMatters web traffic.

To resolve the issue:

  • Review your internal network and security controls (for example, firewall, proxy, or network policy) for rules that may be blocking or inspecting traffic to xMatters.

  • Explicitly allow traffic to the xmatters.com domain (add it to your permit or allow list) in the relevant security or network tools.

  • If needed, capture the browser Console output and a HAR file while reproducing the issue and share them with xMatters Support to help identify the specific blocked request.

Cause

After inspecting the browser certificate and Console output, xMatters Support confirmed that the customer was using zScaler to shape/sniff browser traffic looking for specific keywords. This inspection and filtering caused certain requests to return a 403 error. Alternate words could be saved without a 403 error, which further confirmed that the internal security controls were blocking specific traffic.

More generally, a 403 returned for a GET request in the browser Console after successful authentication typically indicates that traffic is being blocked by an internal control, for example, firewall, proxy, or network policy. In these cases, working with your internal team to permit or allow the required xMatters web app traffic resolves the issue.



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