Receiving an import failure error when trying to import a workflow

Problem

When trying to import a workflow, the following error is returned:

Import workflow invalid file format: The workflow file is not a valid zip file.

The zip file seems okay, and nothing obvious is wrong with the workflow itself.

Environment

All versions of xMatters

Solution

This can happen if a deleted form is referenced in an integration, resulting in an incomplete integration that cannot be imported. To resolve this, check for invalid references or validation errors in the workflow or integration and correct them before attempting the import again.

If you still receive an invalid zip file error when importing a workflow, check that the .zip file is not corrupted by re-downloading it or opening it with a zip utility.

If the issue persists, contact xMatters Support. Include a link to the workflow and attach the exported .zip file so Support can validate the file and attempt an import in a test environment.

Cause

An exported integration may be invalid.

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